X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 10 Preview stats: Two-thirds of testers live dangerously

    http://www.pcworld.com/article/28334...ngerously.html



  • #2
    More than 200,000 suggestions or complaints have been filed via the Windows feedback app,i am one of them,i have a question why my computer becomes slow afer 10-15 days after installing windows 10?even it takes huge time to start,but if i restart it it runs normal,any idea?

    Comment


    • #3
      It's amazing that Windows is still in business if they keep making the shoddy computers and the shoddy software programs to be honest with you. The need for them to step their game up immediately otherwise would end up in a position where everybody is going to have to spend a few thousand dollars to get a Macintosh.

      Comment


      • #4
        i agree westmixxin

        Comment


        • #5
          Never had a Macintosh. How does it run compared to what I'm using now. I have a hp desktop with 8.1 Windows. I often thought about how the Mac is different then the pc,but I have never used one.

          Comment


          • #6
            I haven't yet installed Windows 10 in my computer so I have no complaints. I am waiting for the October version to be released.

            Comment


            • #7
              Originally posted by mooray View Post
              I haven't yet installed Windows 10 in my computer so I have no complaints. I am waiting for the October version to be released.
              When in October is it suppose to be released and if you already have Windows 10 wouldn't it be updated as well or no.

              Comment


              • #8
                Originally posted by smbhossain786 View Post
                More than 200,000 suggestions or complaints have been filed via the Windows feedback app,i am one of them,i have a question why my computer becomes slow afer 10-15 days after installing windows 10?even it takes huge time to start,but if i restart it it runs normal,any idea?
                Are you still having this problem, or has it improved since this post.

                Comment

                Working...
                X